pbootcmsV3.1.5正式发布 不再支持PHP7.0以下版本

92建站   2022-07-07   收藏本文

本文介绍了pbootcmsV3.1.5正式发布了,这个版本除了更新不少新功能外,最重要的可能就是不再支持PHP7.0以下的,正在使用本程序的朋友们在升级新版本时注意升级PHP版本,如果不想使用PHP7以上版本,不要升级PTCMS,不过为了安全起见还是建议大家升级哦。

pbootcms,pbootcms正式版

PbootCMS V3.1.5.dev build 2022-07-04主要升级功能:

1、数据库新增索引以优化大数据量网站的查询速度(sql脚本文件随版本一起发布)

2、新增一键清除上传文件功能(默认清除超过90天的上传文件)根据反馈该功能已取消

3、清理缓存现在也会清理session文件夹 已修改为自动清理超过7天的Session文件夹

4、针对近期挂马屏蔽非法字符串注入(新增)

5、其他已知bug的修复

注意:

从该版本开始,PbootCMS不再支持php7.0以下的版本,请需要更新的用户先升级php版本至7.0+

因数据库新增了索引,需要执行sql脚本文件才能正常使用,所以该版本不兼容V3.1.5以下的版本

优化了索引查询,可兼容V3.1.5以下版本,建议使用sqlite的大数据量用户迁移至mysql进行体验

sql脚本文件路径  /static/backup/sql/sqlite-3.1.5-update.sql、/static/backup/sql/mysql-3.1.5-update.sql,如果在线更新没有拉取到sql文件可在gitee上进行下载,链接:https://gitee.com/hnaoyun/PbootCMS/tree/dev/static/backup/sql

请需要升级的用户后台切换分支至测试版进行升级,升级前请先保存好网站数据,以免造成数据丢失

展开